If the CloudGate Universe or CloudGate on-device web interface does not display correctly, reports error messages, or does not display at all, make sure that your PC meets the following minimum browser requirements:

 

For the CloudGate universe:

 

  • Chrome 27.0(.1453.110 m)
  • Firefox 21.0
  • Internet Explorer 10(.0.9200.16540)
  • Safari 5.1

 

 

For the Cloudgate device web interface:

 

  • Internet Explorer  9
  • Safari 5.1
  • Firefox (Windows 21.0, Mac 12.0)
  • Chrome (Windows 27.0.1453.110,  Mac 26.0.1410.65)
  • Opera (Windows 12.02, Mac 12.10)